Why are my images breaking in my Actions confirmation emails?

created

Problem:

You have confirmation emails set up to go out for Actions - and you have images in the emails to spice them up a bit.  But, you've discovered that when the emails are sent and viewed by the recipient... the images are broken!  So, what's going on there?

What's going on?

The most likely cause is that the WYSIWYG editor has been set to use "relative" URLs, instead of "absolute" URL.

What do those fancy words mean?

Well, a relative URL looks like this:

/onething/anotherthing/file.png

Notice that it doesn't have the domain name at the front of it?  Whereas an absolute URL will look like this:

http://yoursite.com/onething/anotherthing/file.png

Do you see the difference?

As long as you are viewing the image on your own site, it's fine if the URL is relative.  Your browser knows to take the base domain name of the site (http://yoursite.com) and add it to the beginning of the relative URL to get the full path to the image.  It works great!

The problem arises when you try to view the image somewhere that's not on your site - e.g. in your email client.  The email client doesn't have the same domain name as your website so - and you may have already guessed it - it tries to plug in the wrong domain name and reach the image using a URL that doesn't work.

And so the image link breaks.

How to resolve:

Soapbox can be set to use absolute URLs instead of relative URLs.  This is a configuration that our Support staff will be happy to do for you. If you open a ticket and let us know you need help with this we can make the adjustment pretty quickly.

Have more questions? Submit a request
Article is closed for comments.