Issue
Users may encounter the error message “Salesforce Error: Use one of these records?” This typically occurs in the following situations:
- When someone submits a Soapbox Engage form (donation, event registration, etc.)
- When a Soapbox administrator clicks “Create Lead” on a transaction record
Cause
This error is triggered by duplicate rule settings. Salesforce has identified a potential duplicate record and requires a human to confirm which record is correct.
When the Standard Salesforce Duplicate Rule is enabled and set to Allow and Alert, the “Alert” portion prompts this error message and prevents the Lead record from being created until a decision is made.
Solution
To prevent this error and allow Lead records to be created without interruption:
- Go to Salesforce Setup.
- Navigate to Duplicate Rules.
- Locate the Standard Rule for Leads with Duplicate Contacts
- Edit the rule and disable the “Alert” option (change from Allow and Alert to Allow).
- Save your changes.
With this adjustment, the Soapbox Engage duplicate matching rules will still run and Salesforce will not stop the Lead from being created for human intervention.